Beamposition queries broken or disabled or unsupported on your setup!

Hi All

Previously, I have installed psychtoolbox on 2 computers with great success.

20.04 LTS + AMD RX570 (Desktop) + MATLAB 2021b
20.04 LTS + INTEL UHD (Desktop) + MATLAB 2020b

Recently, I tried installing psychtoolbox on a laptop with INTEL Xe onboard graphics. After installation, I would typically run BeampositionTest, VBLSyncTest, etc. to ensure that the system is working properly before we use it for experiments. Even though I have used the same installation method as before, I have encountered an error that is new to me, and I am unable to resolve it.

This is the following error:
PTB-INFO: OpenGL-Renderer is Intel :: Mesa Intel(R) Xe Graphics (TGL GT2) :: 4.6 (Compatibility Profile) Mesa 21.0.3
PTB-INFO: VBL startline = 1080 , VBL Endline = -1
PTB-INFO: Will try to use OS-Builtin OpenML sync control support for accurate Flip timestamping.
PTB-INFO: Measured monitor refresh interval from VBLsync = 16.661839 ms [60.017383 Hz]. (50 valid samples taken, stddev=0.006028 ms.)
PTB-INFO: Reported monitor refresh interval from operating system = 16.661390 ms [60.019001 Hz].
PTB-INFO: Small deviations between reported values are normal and no reason to worry.
WARNING: Beamposition queries broken or disabled or unsupported on your setup!

The BeamPosition: Screen 0 plot shows a flat line at -1.
The BeamPosition against Timestamp plot shows a flat line at -1 as well.

I have tried troubleshooting this issue by

  1. DisplayOutputMappings
  2. SyncTrouble

I am wondering if anyone else have similar issues previously and could point me in the right direction.

Kind Regards
Alvin Lee

That’s normal on Intel graphics. Beamposition queries are only supported on NVidia and on slightly older AMD (up to and including AMD Vega), not on Intel or on graphics chips like the RaspberryPi.

No reason to worry, as the OS supported diagnostic and timestamping methods are at least as reliable and accurate as beamposition queries. Indeed, whenever you use an open-source (Mesa) graphics driver, beamposition queries are just another measure to verify and check, not the primary method of timing or correctness checks. Your output looks fine, not pointing at any problems. If you check on your existing Intel UHD setup, you will find the same behaviour.


Btw. this is not related to your question, but one real current limitation of the latest two generations of Intel graphics chips (Icelake and Tigerlake aka “Intel Xe”) under current Linux distributions is that you can only use 8 bpc framebuffers, with “millions of colors”, not 10 bpc high precision framebuffers (1 billion colors). On Icelake this is a limitation of the X-Server which will be fixed in future Linux distributions with the new X-Server 21.1. On Tigerlake “Intel Xe” this is some kind of hardware design flaw, for which a workaround is in the making, but not yet implemented. Hopefully these chips will regain > 8 bpc deep color support by the time Ubuntu 22.04-LTS arrives in April next year. I contributed some of the work in diagnosing some of these issues, but could not actually test if my work actually works. Unfortunately the lack of financial support for us by over 99.9% of our users means lack of funding → lack of money for new hardware and testing time → lack of testing and proactive work by myself → less reliability for the hardware i can’t afford, not only for Psychtoolbox users, but also for users of other toolkits. So atm. Intel chips from the 2010 - 2018/19 era have more color precision than the most recent models.