CMUbox with linux

Hi, trying to make the switch to Linux from Windows as urged by he PTB community, but am running into issues. Have a CMUbox we’re using for voice onset latency measure with an ftdi type USB to serial converter. It worked fine under Windows with PsychToolbox. Am getting errors under Linux. Specifics follow:

Ubuntu 18.04.5 LTS
Optiplex 990
Matlab (R2021a) Update 4
Psychtoolbox Version 3.0.17
PST Model 200A response box.

Under Windows, the command was: info.pstHandle=CMUBox(‘Open’,‘pst’,‘COM5’,‘ftdi’);

Under Linux, the result is:
Error in function OpenSerialPort: Usage error
Error opening serial port device COM5 - No such serial port device exists! (2) [ENOENT].

when I tried: info.pstHandle=CMUBox(‘Open’,‘pst’,’’,‘ftdi’);

the result is:
Error setting receive latency for device /dev/ttyUSB0 to low latency mode - Inappropriate ioctl for device(25).
Error in function OpenSerialPort: Usage error
Error changing device settings for device /dev/ttyUSB0 - Inappropriate ioctl for device(25).

I’m not sure what Ubuntu wants instead of the COM parameter.

Or does it need a driver to be installed?

I disabled the VCP driver in favor of the D2XX driver since this is what our RTbox wanted in order to function. Does the CMUbox need the VCP driver? I suppose we could convert to using the RTbox for the voice onset, assuming it can handle that, but am reluctant to make further changes from something that has been working for us.

Any suggestions welcome!


Suggestion: ‘help PsychPaidSupportAndServices’ will instruct you how to get paid priority support, if you need pro help to look into this.

Have a nice weekend,