Eyelink: Cannot solve error 'Invalid MEX-file'

I am trying to run a script on MATLAB using the psychtoolbox, but I keep getting this error - ‘Invalid MEX-file ‘C:\toolbox\Psychtoolbox\PsychBasic\MatlabWindowsFilesR2007a\Eyelink.mexw64’: The specified module could not be found.’

The mex file is right there when I go into the MatlabWindowsFiles folder, and I have installed the GStreamer runtime and vcredist. I have also tried the Dependency Walker to find missing .dll files, and everything is added to my path, but I still get the error.

I am working on a Windows 10 laptop with a 64-bit operating system and a x64-based processor. The MATLAB versions I have is R2020b.

I cannot think of anything else to try so any suggestions would be greatly appreciated.

Thank you!

Have you installed the eyelink sdk?

I have installed the psychtoolbox-3 which says it has the Eyelink toolbox features included - I cannot find a way to download the eyelink sdk (do you have a link to the page that will let me install it?)

its on their support forum. You have the features (that the eyelink mex), but not its dependencies.

1 Like

Did you manage to solve this issue? I have the same problem, I also downloaded and installed eyelink sdk but the same error appears.

Nevermind, I resolved my problem - by restarting the computer :slight_smile: (the above solution works)