Can't access GUI screen , going right to dev/sda5: clean, #/# files #/# blocks. Using Linux and Ubuntu on PC

This problem occurred after I tried to fix a login loop at the GUI page. I tried many things and lastly attempted

sudo apt update
sudo apt-get -y dist-upgrade
sudo apt-get -y autoremove
sudo apt-get -y clean

I did auto remove before the dist-upgrade (accidently) so then tried it in the proper order to no avail. The GUI page is gone. It now brings me to the /dva/sda5 page and I can access the terminals for a moment before it switches back to that screen. To type commands I constantly switch to the tty2 or 3 terminals every couple seconds. The computer is running MatLab 64-Bit (Version 3.0.16) with(Ubuntu 20.04). We are using the built in MESA and drivers. I have been trying to fix this for weeks without success. Should I uninstall, reinstall ubuntu? There is data on the program I can not risk losing.

Try and read through your XOrg logs, that should define what is going wrong. Did you try a safe boot?

A slightly oddball suggestion is to try to upgrade to a new MESA version, for example the kisak PPA:

If you get enough time to type in the commands of course! I had a similar problem (X server failed to start) on one machine and forcing a new MESA upgrade fixed it. As your m

Do you have SSHd running on that machine, as you could SSH in and that would make it easier to run commands.

I tried to excess my Xorg logs with the command /var/log/Xorg.0.log. The response was Bash: /var/log/Xorg.0.log permission denied. I then tried Sudo /var/log/Xorg.0.log and the response was command not found. I tried /var/log/Xorg.1.log and the response was: Bash /var/log/Xorg.1.log no such file or directory no such file or directory. I can access a terminal and use it in the safe boot. I found no success in finding the Xlogs there either, or installing the Kisak-mesa fresh PPA. I used the Dmesag command to get some info on the kernel instead. I have attached an image of that result. There is, in orange, an error, “[amdgpu] “VGACON disables amdgpu kernel modeseting”: I attempted to install it in the safe boot as well as the terminal flashing in and out. Sudo add-apt-repository ppa:kisak/kisak-mesa did not result in a key or give any response. The sudo apt update resulted in a list of failures to connect a variety of things which I have attached an image of. Do you know of another way to excess the Xorg logs to hopefully find the problem. Thank you for all the help!


Here is the DMesag results. The first image above is the sudo apt update results after trying to add the kisak ppa.

A log is just a text file so you need to use an pager or editor to open it, like sudo nano /var/log/Xorg.0.log or sudo less /var/log/Xorg.0.log etc.

Perhaps check for your XOrg logs in ~/.local/share/xorg/

Your apt looks very messy, you seem to have both oibaf and kisak MESA PPAs. Probably it is best to first remove both (their PPA pages give instructions how to remove them using the ppa-purge command), and try to boot first with all PPAs removed. It seems you are not connected to the internet either…

By the way you can just take out the hard disk and mount it on another computer to copy off any valuable data before reinstalling Ubuntu. Or use something like clonezilla which allows you to back up a Linux partition to a file…

In the menu showing up after selecting safe boot or recovery system there is also some option, i think at the top, a la “Continue booting” or whatever, which would try to boot into the regular desktop, but with hardware accelerated graphics disabled. That might be worth a try to get data off the machine or use the regular desktop, even in slow motion.

That menu also allows to enable networking, which is off by default, unless you request an enable. And some other auto-repair options…

The place to look if, after entering the password at the login prompt, the login aborts and throws you back to the login screen, would be the log files in ~/.local/share/xorg/, e.g., ~/.local/share/xorg/Xorg.0.log

My feeling is that this setup may have been repaired to death, if all kind of random things have been tried with limited understanding, or at least that it might be much faster to reinstall anyway, given that that takes way less than an hour with a machine equipped with an SSD drive.