Unable to download psychtoolbox missing svn

Hello all,

I am trying to download the toolbox on a new mac (worked perfectly on older ones). It fails as it cannot find the svn, and an online search yielded this is due to the new Catalina. I found different solutions and tried to follow them. Namely, I did the following:

  1. install the standalone Command Line Tools package instead:sudo rm -rf /Library/Developer/CommandLineTools
  2. sudo xcode-select --install
    It didn’t work so I installed it with brew;
    brew install svn

But Matlab still didn’t recognize it.

I also downloaded the subversion installer subversion_installer_1.11.sh following the help instructions, but got the following message on my terminal:
“Your operating system is not currently supported”.

I located svn files on my mac. One of them is at /usr/local/bin/, so I tried to define it in the DownloadPsychtoolbox file (line 513, where svnpath = which(‘svn.’); didn’t find any svn file) and it also didn’t work.

Any solutions?..

Many thanks!!

Apparently the previous workarounds for 10.15 of manually installing command line tools do no longer work as of macOS 10.15.4, because the iToys company put in some more work to make sure that solution is properly broken on their trainwreck operating system as well. If they only would put half as much time into fixing their OS as they do screwing over their dearly paying customers…

It is weird though that a "brew install"ed subversion would not be usable? Did you type “brew install subversion”, or truly “brew install svn”, because the former seems to be the right one? Our DownloadPsychtoolbox.m script specifically probes if a /usr/local/bin/svn executable exists and tries to use it, without you needing to modify anything.

Can you “ls -l /usr/local/bin/svn” and maybe “more /usr/local/bin/svn” to see if that is actually an executable, and see what calling /usr/local/bin/svn does? And if “which svn” points to the same location? It sounds to me as if somehow svn is redirected to Apples broken svn proxy executable?
Please provide the info requested in this post, and probably do the manual download suggested there for now: