XOrgConfCreator not prompting VRR settings for fine-grained visual stimulation timing

Dear members

I am currently setting up a new system requiring the VRR function. Things went pretty well till I ran into issue with the XOrgConfCreator NOT prompting me to setup VRR.

Here are my steps for installation

  1. NeuroDebian
  2. Psychtoolbox (through source code zip file)
  3. PsychLinuxConfiguration
  4. sudo apt install –install-recommends linux-lowlatency-hwe-18.04-edge xserver-xorg-hwe-18.04
    (this should be unnecessary but I tried it anyway ), reboot
  5. XOrgConfCreator:
    After selecting yes to configure special/advanced settings. Somehow, I was only prompted to “setup 30bit framebuffer for 10 bpc precision per color channel”, then directed to saving directory without further options for setting up functions such as VRR.

I suspected that perhaps FreeSync was not enable properly, so I tried (and successfully) to manually enable FreeSync and modify V-Sync globally following the instruction provided by AMD, but still was not prompt to setup VRR running the XOrgConfCreator script. Wondering if anyone might have ran into similar issue?

p.s. I’ve follow same procedure for installation without issue on similar hardware (the only difference being the RX580 graphics card, instead of the current RX570) before, not sure what seemed to be the issue here.


  • intel i7 10700
  • AMD RX570
  • MSI MAG motherboard 8460M
  • MSI 240Hz FreeSync compatible Monitor

Software environment:

  • Ubuntu 20.04 LTS
  • Matlab 2019b
  • GPU Driver : xf86-videoamdgpu-pro DOX video driver (latest gpu driver i can find)
  • Psychtoolbox3 Version 3.0.16

Any help or comment is appreciated, thanks in advance.



Do you mean the amdgpu-pro driver, installed from a download from AMD’s website, instead of the standard driver that is active by default on a Ubuntu 20.04-LTS system? That’s not recommended, unless specifically advised in special cases.

Maybe uninstall that stuff, reboot, make sure you run the standard Ubuntu 20.04-LTS setup? I’ll have a look into XOrgConfCreator if there’s something else amiss. But i do not test AMD at all with anything but the standard driver installation on mostly Ubuntu 20.04 LTS (, or 18.04-LTS in the past and now occassionally). The open-source drivers built into the operating system are almost always the best choice. With the amdgpu-pro stack, selecting for the open-source components only will usually still be fine, they are just “sneak-previews” of what would show up in future official Linux distributions anyway. The proprietary components in the -pro stack are in my experience often of much poorer quality, reflecting the inferior closed-source development process of those drivers.

Another note: Depending on your specific use of PTB VRR features, choosing an AMD Vega graphics card or later model may bring additional precision and stability in fine-grained stimulation timing. Vega has the DCE12 display engine which has improvements in the FreeSync hardware which can be quite useful for visual stimulation. So do later models of AMD hw.

1 Like

Thanks for the swift reply,

Yes, this is exactly what I installed.

Thanks for the advice, I’ll try to install a fresh copy of updated Ubuntu 20.04-LTS (just to be safe), without the AMD Pro driver.

I checked and yes, VRR will not be offered if you installed amdgpu-pro’s proprietary OpenGL library instead of the higher quality, more feature rich, generally higher performance Mesa open-source OpenGL library which is the default. So uninstalling amdgpu-pro is the right fix.

I think it comes with an uninstall script, which hopefully works (did in the past for me, ie. more than 1.5 years ago when i last tested it) and will save you a bit time compared to a full OS reinstall. But ofc. a fresh install of the OS is also an option if you want it squeaky clean.

The VRR/FreeSync/Fine-grained timing support on Linux + AMD (and hopefully Intel and other open-source friendly graphics cards in the future) is currently my favorite personal PTB pet feature which i’m most excited about. I intend to spend a lot more time improving that, hopefully next year. So if you can share some details about how you intend to use it, that could be helpful to guide future development.


Just in case somebody running into similar problem, the simplest solution is to NOT install the AMD provided driver, just use the one form Ubuntu as Mario Kleiner kindly suggested.