GStreamer through Homebrew on macOS supported currently?

Just checking on whether GStreamer installed via Homebrew on Mac is currently supported? I tried it, installing of:


…but get the error below when trying to play a movie. Is there something easy I’m missing or is a Homebrew install not supported at this time? (p.s. The reason I tried Homebrew is that the regular Mac installer seemingly doesn’t come with a way to uninstall or even update to a later version of GStreamer in the future, and no instructions as to how to do so manually are on the GStreamer site.)

PTB-ERROR: Failed to create GStreamer playbin element! Your GStreamer installation is
PTB-ERROR: incomplete or damaged and misses at least the gst-plugins-base set of plugins!
error: PsychError_system
general description: Error reported by a system call
specific description: Opening the movie failed. GStreamer configuration problem.
module name: Screen
subfunction call: OpenMovie
file name: /Users/kleinerm/projects/OpenGLPsychtoolbox/Psychtoolbox-3/PsychSourceGL/Source/Common/Screen/PsychMovieSupportGStreamer.c
function name: PsychGSCreateMovie
line number: 1401

Just use the official installer. It is a pkg file, which can be easily explored by the awesome tool suspicious package (brew info suspicious-package). PKG file leave receipts and the installer does properly update older versions…

What Ian says. I don’t know if current GStreamer from Homebrew is good enough, but probably not. We use a “weak linking” method on macOS which makes GStreamer optional, ie. Screen also works without mandatory GStreamer install. Well, sort of, as our high quality text renderer plugin also depends on libfontconfig provided by GStreamer iirc., but that can also come from Homebrew or other sources. Without the libfontconfig, the old unsupported lower quality/performance and buggy macOS native text renderer would be used.

Could be that the weak linking doesn’t work with GStreamer from sources like Homebrew, or some other link differences. Could also be that some required plugins are missing from your homebrew install, e.g., proprietary codecs.

Update: Actually, it does say that the “playbin” element from “gst-plugins-base” is missing, so I guess that element is missing in Homebrew, or of some incompatible version or kind.

Anything but the standard GStreamer installer is certainly not tested or officially supported by us. No time for such stuff, no money/funding to buy the time.