Problem with NeuroDebian install

I have a few machines with Ubuntu 20.04 and Matlab R2019b. I’ve been going through installing PTB on them. It was working fine via NeuroDebian, but then suddenly as I moved to do this on a new machine a couple weeks ago the NeuroDebian install failed (couldn’t seem to find the server). Then today I tried again, and after following the NeuroDebian steps the post-install stuff didn’t happen. That is, I did this:

wget -O- | sudo tee /etc/apt/sources.list.d/neurodebian.sources.list sudo apt-key adv --recv-keys --keyserver hkps:// 0xA5D32F012649A5A9
sudo apt-get update
sudo apt-get install matlab-psychtoolbox-3

After the final command, it just returned without running any post-install routines. For example the ptb3-matlab link was not created, and none of the ptb directories were added to the Matlab path. I’m used to that happening automatically, and it did as recent as a few weeks ago. Two questions:

1 - did anything change, maybe there’s a problem with the NeuroDebian package?
2 - is there a way I can manually run those post-install routines?


I think I have a clue - this morning the neuro Debian pages pointed to an install with the word “common” in the package name. Now it points to matlab-psychtoolbox-3. Maybe I just need to reinstall with that new package?

There are multiple packages installed for each psychtoolbox install, so your clue is likely wrong.

As far as i can see, what you did to setup your machine matches exactly what ND tells you to do if you want to download from the servers at Darthmouth College.

There was no change at all from our side, and i’m not aware of an intentional change on ND’s side. If this does not work, then it is a problem with NeuroDebian and you should contact them for help.

I would try switching to a different download server, in case only Darthmouth is in trouble, but that’s just a hunch - no expert here, only the ND folks can know what goes potentially wrong.

I should note that ND’s response towards packaging new PTB releases has been extremely sluggish lately. Their packages are currently from December 2020, six months behind current PTB beta, pretty outdated. Maybe a case of a severely overloaded maintainer.


Thanks. Please ignore what I said about “common” - I misremembered.

I checked on our computer and what we ran was actually this:
sudo apt-get install matlab-psychtoolbox-3-nonfree
This is actually what showed up yesterday when I was clicking through NeuroDebian for instructions/code
But then later in the evening it showed:
sudo apt-get install matlab-psychtoolbox-3

So it seems something was being updated on the NeuroDebian site, or perhaps I just misclicked on something. In any case, today I ran sudo apt-get install matlab-psychtoolbox-3 and it seemed to work, with the ptb3-matlab command working after the install was complete.

But in general your comments about the lag in the NeuroDebian updates are consistent with what I’ve seen in the past couple weeks - servers down and unable to install things, and then yesterday (potentially, if it wasn’t my mistake) some sort of glitch which resulted in the wrong commands.

Thanks for the help. Seems to be working now.

Our download instructions on our website seem to be quite unambiguous to me about what package one should install, providing links to the specific ND webpages:

sudo apt install matlab-psychtoolbox-3 for the Matlab version,
sudo apt install octave-psychtoolbox-3 for the Octave version.

All other packages are automatically pulled in as needed.

I could see things going sideways if you installed one of the other packages.

I’m pinging Yaroslav every 2 weeks to update to the latest PTB, and each time he promises to get to it next weekend, and each time nothing happens. I assume ND is still volunteer work, and he probably has a lot of other things on his plate. Given how little the neuroscience community seems to care about the quality and health and sustainability of their software tools, as we can see ourselves from the lack of uptake for our rather cheap community memberships with priority support, i deeply sympathize with any unpaid or underpaid volunteers who just throw in the towel or burn out at some point, although i don’t know if this is the case for ND, or if it is just some temporary overload on the maintainer side, possibly caused by the ripple effects of the pandemic and similar causes, or constantly increasing workload with same amount of resources. Time will tell…


I think people can ignore my post. What I did is follow the link here:
Which took me to the NeuroDebian page with the install. From there either my mistake, or a glitch on the site, led me to install the “-nonfree” version, which I think was the source of the problem. All is well now.